Category Archives: IPV6

IPV6 Basic configuration

Ipv6duals05152018
## Enables forwarding of IPV6 unicast datagrams globally.
ipv6 unicast-routing

## Assigning a manual ipv6 address
interface FastEthernet0/0
no ip address
ipv6 address FE80::2 link-local
ipv6 address 2600:123:123:12::2/64

! Link local address are crital, Because everything that your router sends out is

going to be source to a link-locall address (default way).

Verification command:
ping xxxx
show ipv6 interface XX
show ipv6 int brief xx
show ipv6 neighbor

! IPv6 Neighbor reachability state
1. Incomplete – No response on the req.
2. Reachable – Traffic recently going backandfort.
3. Stale – Valid but there’s no recent traffic seen. (Not a bad thing)
4. Delay – Means you need to send information out to verify the neighbor because

RTR trying to get to the neighbor but not receiving anything back.
5. Probe – Same with Delay.

## EUI-64 Manual addressing but use EUI-64 instead.
interface FastEthernet0/0
no ip address
ipv6 address 2600:123:23:23::1/64 eui-64

## Announce Router information
interface FastEthernet0/0
no ip address
ipv6 address 2600:123:123:13::2/64
ipv6 nd ra-interval 30 (Default 200)
ipv6 nd ra lifetime 3600 (Lifetime is good for an hour default is 30min)
ipv6 nd prefix 2600:123:123:13::/64 (Default value valid for 30day \ 7days)

## Configuring static routes
ipv6 route 2600:111:111:100::9/128(Destination) 2600:123:123:12::1(next-hop)

## Configuring Static default route
ipv6 route ::/0 2600:123:123:12::1

## Configuring BGP on R1 & R3
router bgp 1
no synchronization
bgp router-id 1.1.1.1
bgp log-neighbor-changes
redistribute static
neighbor 10.1.2.2 remote-as 2
neighbor 2600:123:123:13::2 remote-as 2
neighbor 2600:123:123:13::2 soft-reconfiguration inbound
no auto-summary
!
address-family ipv6
redistribute static
no synchronization
neighbor 2600:123:123:13::2 activate
exit-address-family

router bgp 2
no synchronization
bgp router-id 2.2.2.2
bgp log-neighbor-changes
network 192.168.100.9 mask 255.255.255.255
neighbor 10.1.2.1 remote-as 1
neighbor 2600:123:123:13::1 remote-as 1
neighbor 2600:123:123:13::1 update-source FastEthernet1/0
neighbor 2600:123:123:13::1 soft-reconfiguration inbound
no auto-summary
!
address-family ipv6
network 2600:111:111:100::9/128
neighbor 2600:123:123:13::1 activate
exit-address-family

IPV6 BGP ROUTING TABLE
R1#sh bgp ipv6 unicast
BGP table version is 3, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

Network Next Hop Metric LocPrf Weight Path
*> 2600:111:111:100::9/128
2600:123:123:13::2
0 0 2 i
*> 2600:222:222:200::9/128
2600:123:123:12::2
0 32768 ?

R3#sh bgp ipv6 unicast
BGP table version is 3, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

Network Next Hop Metric LocPrf Weight Path
*> 2600:111:111:100::9/128
:: 0 32768 i
*> 2600:222:222:200::9/128
2600:123:123:13::1
0 0 1 ?

IPv6 BGP Setup Tutorial
http://www.ciscopress.com/articles/article.asp?p=777892
http://www.occaid.org/tutorial-ipv6bgp.html
https://networkengineering.stackexchange.com/questions/510/how-to-choose-a-bgp-router-id-when-using-ipv6-only

When an interface in a Cisco networking device is configured with both an IPv4 and an IPv6 address, the interface forwards both IPv4 and IPv6 traffic—the interface can send and receive data on both IPv4 and IPv6 networks.

Configuring IPv4 and IPv6 Protocol Stacks on ASR

SUMMARY STEPS
1. configure
2. interface type interface-path-id
3. ipv4 address ip-address mask [secondary]
4. ipv6 address ipv6-prefix/prefix-length [eui-64]
5. commit

https://www.cisco.com/c/en/us/td/docs/routers/asr9000/software/asr9k_r5-3/addr-serv/configuration/guide/b-ipaddr-cg53asr9k/b-ipaddr-cg53asr9k_chapter_01001.pdf

IPv6 and IPv4 Dual Stack on a Branch Router Configuration Example
http://docwiki.cisco.com/wiki/IPv6_and_IPv4_Dual_Stack_on_a_Branch_Router_Configuration_Example
https://www.cisco.com/c/en/us/products/collateral/ios-nx-os-software/enterprise-ipv6-solution/white_paper_c11-676278.html

IPV6 Redistribution
https://www.cisco.com/c/en/us/support/docs/ip/ip-version-6-ipv6/113598-redis-ipv6-default-route-00.html

Advertisements

IPV6

IPv6 works the same as IPv4 for purposes of IP assignment, routing, and more. But rather than use dotted decimal notation as we do with IPv4, this has been changed to a slightly different notation to prevent confusion. This notation swaps colons (:) for dots. It also changes from decimal to hexadecimal notation (to keep the numbers manageable), and just plain has more of them, specifically, it has 8 groups of them.

Now a couple of rules:
1. leading zeros may be dropped, so 05c0 becomes 5c0, and 0001 becomes 1
2. one time, and one time only, you may drop contiguous zeros completely and just use ::
Using the rules above, the IP 2001:05c0:9168:0000:0000:0000:0000:0001 becomes 2001:05c0:9168::1

http://www.linux-sxs.org/networking/ipv6_for_beginners.html
https://www.networkworld.com/article/2228449/microsoft-subnet/microsoft-subnet-ipv6-addressing-subnets-private-addresses.html
https://networklessons.com/ipv6/how-to-find-ipv6-prefix/